首页
首页
文章目录
  1. Centos7.3部署L2TP中遇到的奇葩问题

Centos7.3部署L2TP中遇到的奇葩问题

Centos7.3部署L2TP中遇到的奇葩问题

今天公司其他部门需要一个vpn,想着今天自己还算有空,就准备给部署一下

系统:Centos7.3

开搞:

1
yum install -y openswan ppp xl2tpd

直接报错

1
2
3
4
5
Error: Package: xl2tpd-1.3.8-1.el7.x86_64 (epel)
Requires: kmod(l2tp_ppp.ko)

You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

提示依赖问题:

1
yum install kmod

提示我已经安装了

>The bug is in an EPEL product, not in CentOS. Incidentally the corrected version should be available soon ( if not already )

>In the future please open bugs for EPEL packages in bugzilla.redhat.com, not here as EPEL and CentOS are separate projects.

然后居然是Centos把锅扔给了EPEL,说是他们包的问题Centos系统没任何关系。。

我不想管他们怎么扯淡,我只想安装xl2tpd部署个vpn而已。

最后解决办法:

下载老版本安装
1
2
3
wget http://dl.fedoraproject.org/pub/epel/testing/7/x86_64/x/xl2tpd-1.3.8-2.el7.x86_64.rpm 

rpm -ivh xl2tpd-1.3.8-2.el7.x86_64.rpm

没报错,之后就是一些基本配置,我就不贴了,而且不想手动配置,也可以从网上找一键安装脚本

支持一下
扫一扫,我会更有动力更新
  • 微信扫一扫
  • 支付宝扫一扫